Лабораторные работы по cisco


Лабораторная работа № 11. Настройка VLAN на двух коммутаторах Cisco



бет20/28
Дата19.01.2023
өлшемі2,97 Mb.
#165902
түріСамостоятельная работа
1   ...   16   17   18   19   20   21   22   23   ...   28
Байланысты:
Laboratornye-raboty-po-setyam-v-CISCO (1)

Лабораторная работа № 11. Настройка VLAN на двух коммутаторах Cisco.


Создайте сеть, логическая топология которой представлена на рис.8.6. Компьютеры соединены коммутатором Cisco 2950-24. В таблице 8.2 приведены адреса компьютеров.

VLAN 20


VLAN 30

Рис.8.6. Схема сети.


Таблица 8.2.



Компьютер

IP адрес

Коммутатор

Порт коммутатора

Вилан

2_1

10.0.0.1/8

Switch1

1

VLAN 20

2_2

10.0.0.3/8

Switch2

1

VLAN 20

3_1

10.0.0.2/8

Switch1

2

VLAN 30

3_2

10.0.0.4/8

Switch2

2

VLAN 30

Далее будем считать, что 2_1 и 2_2 находятся в VLAN 20, а 3_1 и 3_2 находятся в VLAN 30.


Проверим связность получившейся сети. Для этого пропингуем с 2_1 все остальные компьютеры. Поскольку пока в сети нет разделения на VLAN, то все компьютеры должны быть доступны.


Теперь займемся настройкой VLAN 20 и VLAN30, чтобы структурировать сети на коммутаторах.


Перейдите к настройке коммутатора Switch1. Откройте его консоль. В открывшемся окне перейдите на вкладку CLI, войдите в привилегированный режим и настройте VLAN 20 и VLAN30 согласно таблице 2.

Создайте на коммутаторе VLAN 20. Для этого в привилегированном режиме выполните следующую команду:


Switch1#conf t


Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#

для перехода в режим конфигурации и настройте VLAN 20 и VLAN 30 следующим образом:


Switch1(config)#vlan 20


Switch1(config)#interface fastEthernet 0/1
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 20
Switch1(config-if-range)#exit
Switch1(config)#vlan 30
Switch1(config)#interface fastEthernet 0/2
Switch1(config-if-range)#switchport mode access
Switch1(config-if-range)#switchport access vlan 30

Просмотрите информацию о существующих на коммутаторе VLAN-ах командой:


Switch1#sh vl br


У вас должен получится результат, показанный на рис.8.7.





Рис. 8.7. Конфигурация Switch1.


Аналогичным образом сконфигурируйте Switch2 (рис. 8.8).





Рис. 8.7. Конфигурация Switch2.


Поскольку в данный момент нет обмена информации о вилланах, то компьютеры будут пинговать только себя.


Теперь организуем магистраль обмена между коммутаторами. Для этого настроим третий порт на каждом коммутаторе как транковый.

Войдите в консоль коммутатора Switch1 и задайте транковый порт:


Switch1>en


Switch1#conf t
Switch1(config)#interface fastEthernet 0/3
Switch1(config)#switchport mode trunk
Switch1(config)#no shutdown
Switch1(config)#exit

Откройте конфигурацию коммутатора на интерфейсе FastEthernet0/3 и убедитесь, что порт транковый (рис.8.8).





Рис.8.8. Конфигурация интерфейса FastEthernet0/3.


На коммутаторе Switch2 интерфейс FastEthernet0/3 автоматически настроится как транковый.


Теперь компьютеры, входящие в один виллан должны пинговаться. У вас должна появиться связь между компьютерами 2_1 и 2_2, а так же между 3_1 и 3_2. Но компьютеры в другом виллане будут недоступны.


Сохраните схему сети.


Теперь объединим две виртуальные сети с помощью маршрутизатора.


Добавьте в схему сети маршрутизатор, как показано на рис.8.9. Маршрутизатор соединен с интерфейсами fastEthernet 0/4 коммутаторов.

Разобьем нашу сеть 10.0.0.0 на две подсети: 10.2.0.0 и 10.3.0.0. Для этого поменяйте IP адреса и маску подсети на 255.255.0.0, как указано в таблице 8.3.


Таблица 8.3.



Компьютер

IP адрес

Коммутатор

Порт коммутатора

Вилан

2_1

10.2.0.1/16

Switch1

1

VLAN 20

2_2

10.2.0.3/16

Switch2

1

VLAN 20

3_1

10.3.0.2/16

Switch1

2

VLAN 30

3_2

10.3.0.4/16

Switch2

2

VLAN 30

Компьютеры должны пинговаться в пределах одного виллана и одной подсети.





Рис. 8.9. Схема сети.


Обозначим на коммутаторах интерфейсы, подсоединенные к маршрутизатору в виртуальные сети.


Войдите в конфигурацию первого коммутатора Switch1 и задайте параметры четвертого порта:

Switch1(config)#interface fastEthernet 0/4


Switch1(config-if)#switchport access vlan 20

Проверьте настройки первого коммутатора Switch1 (рис.8.10):





Рис.8.10. Настройки коммутатора Switch1.

Войдите в конфигурацию второго коммутатора Switch2 и задайте параметры четвертого порта:


Switch2(config)#interface fastEthernet 0/4


Switch2(config-if)#switchport access vlan 30

Проверьте настройки второго коммутатора Switch2 (рис.8.11):





Рис.8.11. Настройки коммутатора Switch2.


Войдите в конфигурацию маршрутизатора и настройте IP адреса на маршрутизаторе:


Router1(config-if)#interface fa0/0


Router1(config-if)#ip address 10.2.0.254 255.255.0.0
Router1(config-if)#no shutdown
Router1(config-if)#interface fa0/1
Router1(config-if)#ip address 10.3.0.254 255.255.0.0
Router1(config-if)#no shutdown

С этого момента мы установили маршрутизацию между двумя подсетями. Осталось установить шлюзы на компьютерах (таблица 8.4).


Таблица 8.4.



Компьютер

Gataway

2_1

10.2.0.254

2_2

10.2.0.254

3_1

10.3.0.254

3_2

10.3.0.254

Проверьте доступность компьютеров в сети. Теперь все компьютеры должны быть доступны и все адреса должны пинговаться.






Достарыңызбен бөлісу:
1   ...   16   17   18   19   20   21   22   23   ...   28




©engime.org 2023
әкімшілігінің қараңыз

    Басты бет