Лабораторные работы по cisco


Лабораторная работа №8. Настройка протокола OSPF



бет17/28
Дата19.01.2023
өлшемі2,97 Mb.
#165902
түріСамостоятельная работа
1   ...   13   14   15   16   17   18   19   20   ...   28
Байланысты:
Laboratornye-raboty-po-setyam-v-CISCO (1)

Лабораторная работа №8. Настройка протокола OSPF.


Возьмите схему сети, представленную на рис6.1.


Проведем настройку протокола OSPF на маршрутизаторе Router1.


Войдите в конфигурации в консоль роутера и выполните следующие настройки (при вводе команд маску подсети можно не указывать, т.к. она будет браться автоматически из настроек интерфейса роутера):

Войдите в привилегированный режим:


Switch>en

Войдите в режим конфигурации:


Switch1#conf t

Войдите в режим конфигурирования протокола OSPF:


Router1(config)#router ospf 1

В команде router ospf <идентификатор_процесса> под идентификатором


процесса понимается уникальное числовое значение для каждого процесса
роутинга на маршрутизаторе. Данное значение должно быть больше в интервале от 1 до 65535. В OSPF процессам на роутерах одной зоны принято
присваивать один и тот же идентификатор.

Подключите клиентскую сеть к роутеру:


Router1(config-router)#network 10.11.0.0

Подключите вторую сеть к роутеру:


Router1(config-router)#network 10.10.0.0

Задайте использование второй версии протокол OSPF:


Router1(config-router)#version 2

Выйдите из режима конфигурирования протокола OSPF:


Router1(config-router)#exit

Выйдите из консоли настроек:


Router1(config)#exit

Сохраните настройки в память маршрутизатора:


Switch1#write memory

Аналогично проведите настройку протокола OSPF на маршрутизаторе Router2.



Раздел 7. Служба NAT.


NAT (Network Address Translation) — трансляция сетевых адресов, технология, которая позволяет преобразовывать (изменять) IP адреса и порты в сетевых пакетах.

NAT используется чаще всего для осуществления доступа устройств из сети предприятия(дома) в Интернет, либо наоборот для доступа из Интернет на какой-либо ресурс внутри сети.

Сеть предприятия обычно строится на частных IP адресах. Согласно RFC 1918 под частные адреса выделено три блока:

10.0.0.0 — 10.255.255.255 (10.0.0.0/255.0.0.0 (/8))
172.16.0.0 — 172.31.255.255 (172.16.0.0/255.240.0.0 (/12))
192.168.0.0 — 192.168.255.255 (192.168.0.0/255.255.0.0 (/16))

Эти адреса не маршрутизируются в Интернете, и провайдеры должны отбрасывать пакеты с такими IP адресами отправителей или получателей.

Для преобразования частных адресов в Глобальные (маршрутизируемые в Интернете) применяют NAT.

Помимо возможности доступа во внешнюю сеть (Интернет), NAT имеет ещё несколько положительных сторон. Так, например, трансляция сетевых адресов позволяет скрыть внутреннюю структуру сети и ограничить к ней доступ, что повышает безопасность. А ещё эта технология позволяет экономить Глобальные IP адреса, так как под одним глобальным адресом в Интернет может выходить множество хостов.


Настройка NAT на маршрутизаторах Cisco под управлением IOS включает в себя следующие шаги

1. Назначить внутренний (Inside) и внешний (Outside) интерфейсы
Внутренним интерфейсом обычно выступает тот, к которому подключена локальная сеть. Внешним — к которому подключена внешняя сеть, например сеть Интернет провайдера.
2. Определить для кого (каких ip адресов) стоит делать трансляцию.
3. Выбрать какой вид трансляции использовать
4. Осуществить проверку трансляций

Существует три вида трансляции Static NAT, Dynamic NAT, Overloading.

Static NAT — Статический NAT, преобразование IP адреса один к одному, то есть сопоставляется один адрес из внутренней сети с одним адресом из внешней сети.

Dynamic NAT — Динамический NAT, преобразование внутреннего адреса/ов в один из группы внешних адресов. Перед использованием динамической трансляции, нужно задать nat-пул внешних адресов

Overloading — позволяет преобразовывать несколько внутренних адресов в один внешний. Для осуществления такой трансляции используются порты, поэтому иногда такой NAT называют PAT (Port Address Translation). С помощью PAT можно преобразовывать внутренние адреса во внешний адрес, заданный через пул или через адрес на внешнем интерфейсе.

Список команд для настройки NAT:

обозначение Интернет интерфейса:
interface FastEthernet0/0
ip nat outside

обозначение локального интерфейса:


interface Vlan1
ip nat inside

создание списка IP, имеющего доступ к NAT:


ip access-list extended NAT
permit ip host 192.168.???.??? any

включение NAT на внешнем интерфейсе:


ip nat inside source list NAT interface FastEthernet0/0 overload

Посмотреть существующие трансляции можно командой "show ip nat translations".

Отладка запускается командой "debug ip nat"

Настройка Static NAT

router(config)#ip nat inside source static
router(config)#interface fa0/4
router(config-if)#ip nat inside
router(config)#interface fa0/4
router(config-if)#exit
router(config)#interface s0
router(config-if)#ip nat outside

Настройка Dynamic NAT

router(config)#ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length}
router(config)#access-list permit [source-wildcard]
router(config)#ip nat inside source list pool
router(config)#interface fa0/4
router(config-if)#ip nat inside
router(config-if)#exit
router(config)#interface s0
router(config-if)#ip nat outside

Настройка Overloading

router(config)#access-list acl-number permit source-IP source-wildcard
router(config)#ip nat inside source list acl-number interface interface overload
router(config)#interface fa0/4
router(config-if)#ip nat inside
router(config-if)#exit
router(config)#interface s0
router(config-if)#ip nat outside




Достарыңызбен бөлісу:
1   ...   13   14   15   16   17   18   19   20   ...   28




©engime.org 2023
әкімшілігінің қараңыз

    Басты бет